[Unity][Android] Branch never initializes

Hi

I pretty much just started with branch and went through the guides in order to set everything up with Unity (note: I am using Unity 2017.1.0f3)

Everything went smoothly until I got to actually test it on a device. I wanted to try sharing something to test the deeplinks, but nothing happened.

The callback from Branch.shareLink  was never triggered. Neither the one from Branch.getShortURL. Finally, I realized the callback on Branch.initSession was never actually called, which told me Branch was not being initialized.

I put this call on the Start method of a script attached to a gameobject on the very first scene of the game, so I don’t know what to do at this point. I tried using the initSession which requires a callback that returns a BranchCallbackWithBranchUniversalObject and the one with no parameters, neither of which worked.

Any suggestions? Am I missing something from the setup phase?

 

cheers,

 

Victor

BlackHouse — Developer
1 Answer(s)
Answered on July 25, 2017.

Can you please create a ticket for our integrations team here?

Developer
Commented on July 25, 2017.

Hmm, okay

BlackHouse — Developer